ARCmop Java Programacion Solaris Linux

Java-linux-programacion

Solucion WxCam: Imposible abrir /dev/dsp El video se grabará sin pista de audio

Posted by Cmop en noviembre 7, 2009

Wxcamsindsp

Wxcamsindsp

Hola, ya había comentado que estaba usando el WxCam 1.0.4 aqui,en mi instalación de Karmic Koala x64, sobre una HP dv4-1425la, pero existía una molestia, cuando quería grabar teniendo activados los sonidos de Ubuntu o cualquier otra aplicación que este reproduciendo sonido o música, por ejemplo “Audacious”, me pasaba ese dichoso error: “Imposible abrir /dev/dsp El vídeo se grabará sin pista de audio”, pero lo curioso es que cuando ejecutaba WxCam desde un terminal con permisos de root esta restricción desaparecía, opté por dejarlo así, pero el problema apareció después, fue que todos los vídeos grabados debía cambiarle los permisos para poder verlo (esto colmo mi paciencia). Ahora pensé que eran los permisos de /dev/dsp, los cambie a 777 y nada, seguía la misma restricción, excepto como root, después de darle vueltas, aquí la solución:

Se debe instalar alsa-oss, desde la linea de comandos sería:

#sudo apt-get install alsa-oss

Una vez instalado este contenedor, ejecutaremos desde la terminal el WxCam pero anteponiendo el comando “aoss”, asi:

#aoss wxcam

Y listo, veremos que todo va bien y sin ese error tan molesto, si queremos que este cambio se permanente al ejecutarlo desde el menú, hacemos clic derecho en la barra de menús y seleccionamos “Editar los Menús”, buscamos donde esta el “Webcam Application”, lo seleccionamos y damos a “propiedades” y allí en “Comando” anteponemos “aoss” y listo, hacemos clic en cerrar y ya podemos usar WxCam sin problemas invocándolo desde el menú.

Saludos a todos.

4 comentarios to “Solucion WxCam: Imposible abrir /dev/dsp El video se grabará sin pista de audio”

  1. Fabio said

    hola, gracias por la ayuda, pero tengo un molesto problema con WxCam, no me deja cambiar la tamaño del frame, solo permanece en 160 x 120 y no se como cambiarla, mi camara es una msi startCam 370i, lo curioso es que antes de reinstalar ubuntu 9.10 funcionaba a las mil maravillas pero ahora no se porq no me deja, agradeceria cualquier ayuda

  2. Marcelo said

    Fabio:

    Probablemente sea xq tu webcam solo admite como maximo esa resolución… Puedes verificarlo en las especificaciones de tu webcam o probando con otra aplicacion como Cheese.

    Saludos.

  3. Gustavo said

    Hola Marcelo, muchísimas gracias por tu solución. Me alegraste el día! jaja!
    Saludos

  4. kiosake said

    iise lo k posteaste pero tengo otro problema mira

    aoss wxcam
    Determining video4linux API version…
    Using video4linux 2 API
    Determining pixel format…
    pixel format: YUV 4:2:2 (YUYV)
    Found V4L2_PIX_FMT_YUYV pixel format
    Revel Error while starting encoding: 4

    y por eso no me guarda e video en ninguna parte no se k paso ahora a ver se me puedes ayudar

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s

 
A %d blogueros les gusta esto: