ARCmop Java Programacion Solaris Linux

Java-linux-programacion

Configurar Openchrome en Intrepid Ibex con Via S3G UniChrome Pro IGP a 1024×768

Posted by Cmop en diciembre 26, 2008

Hola a todos, comentarles que el 24 de diciembre me llego mi CD de Ubuntu Intrepid Ibex, y decidi instalarlo, pues a pesar de que pude configurar Hardy a mi gusto, no me convencia mucho, el primer problema fue que ubuntu intrepid no me permitia usar la resolucion de 1024×768, en mi PC que es una PCCHIPS P25G la cual tiene un Chipset P4M800, es mas solo podia usar la resolución de 640×350, lo cual es inapropiado para mi, asi que me propuse arreglar esto.

Veamos que es lo que tengo:

  1. Placa base: PCCHIPS P25G, con chipset P4M800.
  2. Tarjeta Grafica Integrada: Via S3G UniChrome Pro IGP
  3. Memoria compartida (VGA share memory size): 64MB
  4. Monitor. CRT Samsung SyncMaster 591s
  5. Ubuntu Intrepid trae consigo el driver xserver-xorg-video-openchrome, el cual es un driver que reemplazo al driver que hizo VIA arena xserver-xorg-video-via_0.2.2-6_i386, y lo reemplazo por ser obsoleto.

Con todo esto empece mi labor, y despues de estar 3 días, trabajando en esto, encontre informacion muy valiosa, sobre como configurar X de manera correcta, y despues de leer muchas soluciones de otros usuarios y tras muchos intentos fallidos, logre solucionarlo:

  • Debemos editar el archivo xorg.conf: #sudo gedit /etc/X11/xorg.conf
  • Despues de escribir nuestra conrtraseña, se abrira gedit ya alli debemos escribir esto:
    # xorg.conf (X.Org X Window System server configuration file)
    #
    # This file was generated by dexconf, the Debian X Configuration tool, using
    # values from the debconf database.
    #
    # Edit this file with caution, and see the xorg.conf manual page.
    # (Type "man xorg.conf" at the shell prompt.)
    #
    # This file is automatically updated on xserver-xorg package upgrades *only*
    # if it has not been modified since the last upgrade of the xserver-xorg
    # package.
    #
    # Note that some configuration settings that could be done previously
    # in this file, now are automatically configured by the server and settings
    # here are ignored.
    #
    # If you have edited this file but would like it to be automatically updated
    # again, run the following command:
    # sudo dpkg-reconfigure -phigh xserver-xorg

    Section "Module"
    Load "bitmap"
    Load "ddc"
    Load "dri"
    Load "extmod"
    Load "freetype"
    Load "glx"
    Load "int10"
    Load "vbe"
    EndSection

    Section "Device"
    Identifier "Tarjeta Integrada"
    driver "openchrome"
    BusID "PCI:1:0:0"
    Option "DisableIRQ"
    Option "ActiveDevice" "CRT"
    Option "XAANoOffscreenPixmaps" "true"
    Option "DRI" "true"
    Option "XaaNoImageWriteRect"
    Option "SWcursor" "true"
    Option "VideoRam" "65536"
    Option "ForcePanel" "true"
    Option "PanelSize" "1024×768"
    EndSection

    Section "Monitor"
    Identifier "monitor01"
    VendorName "Samsung"
    ModelName "Syncmaster 591s"
    HorizSync 30-55
    VertRefresh 50-120
    DisplaySize 270 203 # 1024×768 96dpi

    Modeline "640×480@85" 35.71 640 672 736 832 480 481 484 505 -hsync +vsync
    Modeline "800×600@85" 56.55 800 840 928 1056 600 601 604 630 -hsync +vsync
    Modeline "1024×768@60" 64.11 1024 1080 1184 1344 768 769 772 795 -hsync +vsync

    Option "DPMS" "on"
    EndSection

    Section "Screen"
    Identifier "Pantalla01"
    Monitor "monitor01"
    Device "Tarjeta Integrada"
    DefaultDepth 24
    SubSection "Display"
    Depth 24
    Modes "1024×768" "800×600" "640×480"
    Virtual 1024 768
    EndSubSection
    SubSection "Display"
    Depth 24
    Modes "1024×768" "800×600" "640×480"
    Virtual 800 600
    EndSubSection
    EndSection

    Section "ServerLayout"
    Identifier "Default Layout"
    Screen "Pantalla01"
    EndSection

    Section "DRI"
    Mode 0666
    EndSection

Ahora explicare algunos de los parametros principales, y que difieren de las soluciones que aportaron los demas usuarios, gracias a ellos puede estar listo el mio.

  • Option "ActiveDevice" "CRT".- esta opcion sirve para especificar el tipo de dispositivo de salida, que sta conectadoe, el caso de las laptops se sustituye "CRT" por "LCD,CRT".
  • Option "ForcePanel" "true".- permite forzar la salida del tamaño del panel que se especifica en "PanelSize"
  • Option "PanelSize" "1024×768".- aqui se especifica el tamaño de la salida que se desea usar.
  • Option "VideoRam" "65536".- Esta opcion especifica la cantidad de memoria de la tarjeta Grafica, esta opcion en mi caso es NECESARIA y FUNDAMENTAL, para saber que valor poner multipliquen el valor de su memoria en (MB) por 1024, en mi caso es (64 * 1024=65536), este valor debe especificarse
  • Las lineas del modeline: las extraje del log del xorg, Ubuntu Intrepid al no poder usar la pantalla, genera un error y lanza un mensaje que dice "Ubuntu, graphics low display", despues de esto marcamos las tercera opcion, y nos apareceran unas nuevas opciones, en la cual marcamos "view log", y alli encontraremos los modos que son autodetectados. Otra opcion es usar una herramienta como: Modeline Tool u otra como esta XFree86 modeline Generator
  • BusID "PCI:1:0:0".- este es un parametro que indica el Bus donde se encuentra la tarjeta. Para obtenerlo usamos el comando: #lspci | grep VGA este comando nos dara el BusID en el siguiente formato: XX:XX.X en hexadecimal, lo que debemos hacer es convertirlo a decimal y al formato XX:XX:X, cambiamos el "." por ":", y ademas convertirmos los numero que puedan estar en hexadecimal a decimal.
  • Depth 24.- Este valor puede variar y ser uno de los factores determinantes en algunos casos particulares, determina la profundidad del color, puede ser 1-8-15-16-24, pero no todos pueden ser admitidos por la pc. En este caso es necesario poner 24 pues si ponemos numeros inferiores al reproducir algunos tiposde videos como Xvid,mp4, avis,mpg, entre otros, no se vera el video, solo sonido y una pantalla verde.

Aqui algunos links importantes:

41 comentarios to “Configurar Openchrome en Intrepid Ibex con Via S3G UniChrome Pro IGP a 1024×768”

  1. miguel said

    buen post. sigue asi.

  2. crisdavfac said

    bien por ti, bacan…

  3. […] por cmop17 en Enero 2, 2009 Despues de haber lidiado con la cofiguracion de mi Tarjeta Grafica, ahora me toco liar con la configuracion de mi mouse: un PCTronix M800 OPS2, el cual de un momento […]

  4. Arian said

    No me Funciono el script, me sigue tirando modo consola

    • cmop17 said

      No es un script que se ejecuta desde el terminal, debes abrir el archivo desde el modo consola y completarlo con los parametros que doy. Seria bueno que mostraras el modelo de la PC que tienes, asi como sus caracteristicas, asi seria mucho mas facil ayudarte. Animate y hazlo y veo como te ayudo, saludos.

  5. [Benja] said

    oye tu tarjeta es integrada? y haz logrado correr los efectos con los drivers de VIA?

    Es que he tratado varias veces pero no lo he conseguido, recuerdo que lo logre con la versión 7.10, pero con las ultimas dos no he podido.

    Saludos

    • cmop17 said

      Mi tarjeta claro que si es Integrada, ahora correr los efectos, como por ejemplo Compiz, o desde un principio Beryl, nunca lo he intentado, debido a que no soy a fin a ellos, intentare activarlos y comentare que fue lo que paso. saludos.

      • christopher said

        Porfa, Podrìas decir si funciono? Gracias!

        • Cmop said

          Hola christopher, la verdad no pude activarlos, me tope con mil y un errores durante el proceso de intentar activarlos y sin ningun resultado exitoso, saludos

          • christopher said

            Oks, gracias por responder la verdad k mi compu tiene la misma placa y a lo sumo he logrado ponerlo en pantalla blanca xD! y solo reiniciando logro recuperarlo….

            Entonces no hay otra k comprar una tarjeta modesta…

            Saludos!

          • christopher said

            Creo k no llegó el otro mensaje… Solo logré ponerla en pantalla blanca, probando con los drivers de Via, incluso reinstalando el Mesa para k tenga Rendering xDD!… pues habrá k comprar una tarjeta porque esta placa al contar incluso con 64mb para video no hace ni coskillas para el compiz…

            Saludos!

          • christopher said

            Creo k no llegó el otro mensaje…
            Gracias por responder.
            Solo logré ponerla en pantalla blanca, probando con los drivers de Via, incluso reinstalando el Mesa para k tenga Rendering xDD!… pues habrá k comprar una tarjeta porque esta placa al contar incluso con 64mb para video no hace ni coskillas para el compiz…

            Saludos!

  6. [Benja] said

    ok y gracias por contestar😉
    suerte en la travesía jeje

    Saludos

  7. [Benja] said

    ok y gracias por contestar😉
    suerte en la travesía jeje, estaré pendiente del mensaje.

    Saludos

  8. Tacua_GT said

    Tengo un problema similar con mi monitor. Tiene una resolución de 10024 x 800 sin embargo el sistema me lo carga con una inferior y en el menu “configurar resoloción” no figura la mia. Tengo una laptop Toshiba Satellite L305-SP5806R. Soy absolutamente nuevo en ubuntu (acabo de istalarlo ayer). Me pregunto si la solución que proponen mas arriba podria funcionar en mi mauina?. sepan disculpar mi ignorancia.

    Saludos a todos

  9. cmop17 said

    Por lo que he podido observar en tu laptop usa una Tarjeta Graphica “Mobile Intel Graphics Media Accelerator 4500M con 128MB – 286MB memoria de gráficos compartida dinámicamente asignada”. El problema de resolucion puede deberse a que no tienes el driver actualizado para tu Laptop, en este link dan la lista de archivos necesarios, aqui.
    SI despues de instalar el driver correcto y actualizado, y si aun no funcionara (cosa que dudo), el procedimiento para tu Toshiba, deberia ser parecido al que presento. Pero los parametros a configurar serian distintos.
    Saludos.

  10. Tacua_GT said

    OK, probando.

    Muchas gracias por el dato

  11. Panchakax said

    Te cuento he tratado de instalar intrepid en mi laptop pero sin resultado alguno ya que en modo de graficos bajo se queda pegado y no hace nada como fue que lo instalaste por que a mi se me cuelga con mi tarjeta via sg3 unichrome he tratado con fedora linuxmint kubuntu y suse y nada y estoy desesperada por que no me gusta usar lindows solo quisiera saber como lo hiciste para instalarlo gracias y muy buena tu web

  12. cmop17 said

    A ver Panchakax, para poder ayudarte mas, necesito marca y modelo de tu Laptop, asi podre saber que tipo de driver necesita,y si es realmente el de S3 Unichrome.

    Otra cosa es que deberias decirme si puede correr alguna de esas distros en modo “compatible”, es decir, con la pantalla a baja resolucion (600 x 480 o menor), iconos grandes, es decir si la distro carga por lo menos lo minimo en cuanto a Interfaz Grafica.

    Ademas que Distribucion exactamente deseas tener, porque el driver variara de acuerdo a la distro, para buscar el necesario, deberia poner en google ” “Unihcrome” Nombre_Distro “.

    Espero te comuniques conmigo pues me agraderia ayudarte, poner tu SO de GNU/Linux, saludos.

  13. tengo intalado ubuntu8.10 y no me reconose la targeta grafica Tarjeta Grafica Integrada: Via S3G UniChrome Pro IGP , soy nuevo en el programa necesito ayuda pero urgente por favor

    • cmop17 said

      Hola Doctor henry, si dices que eres nuevo, eh de decirte “Bienvenido al Software Libre”, el primer paso que me falta entonces es:

      1.- Click en la barra de Menu, en “Aplicaciones”–> “Utilidades” –> “Terminal”, y listo con eso ya habrás abierto la consola y podras seguir los pasos a qui descritos y podras usar tu tarjeta VIA con toda la resolucion.

      Cuando hayas habierto el archivo, puedes simplemente copiar y pegar la parte que he puesto alli, que corresponde al archivo “Xorg.conf”, recuerda escribir “Xorg.conf” con “X” mayuscula.

      saludos, si tienes aun problemas no dudes en comentar, saludos.

  14. hola el mensaje que estoy recibiendo no lo entiendo por que no esta especificado bien para mi soy un novato en esto disculpa la molestia bey

  15. Adolfo said

    Saludos amigo,

    Bueno he instalado la version Ubuntu 8.10 sin problemas y puedo cambiar las resoluciones de pantalla sin problema, pero no creo que este usando la aceleracion grafica.

    Datos de mi pc:
    ASRock P4VM800 Motherboard Intel Celeron D con memoria ram 2 gb

    OnBoard VGA: S3 Unichrome Pro 3D/2D Graphics Controller,
    supports DX7 H / W

    Segui los pasos que indicas para modificar el xorg.conf, sacando los datos del log del xconf, pero cuando reincie me dio un error y me dijo que estaba en grafica de baja resolucion, pude repar eso y volver como al inicio, pero no puedo utilizar la aceleracion grafica.

    Mucho te agradeceria pudieras ayudarme.

    Gracias

  16. Muchisimas gracias amigo Dios te bendiga por tu aporte gracias!

  17. leo said

    Como hago para Actualizar los drivers de mi placa de video :(via/s3g unichrome pro igp,, No tengo el cd y no puedo Encontrar los drivers :S

    • cmop17 said

      Si estas utilizando la version 8.04 u 8.10 de Ubuntu no necesitas nada mas que el CD de Ubuntu, lo instalas y despeus sigues los pasos, que menciono, saludos.

  18. Fernando said

    acabo de actualizar a ubuntu 9.04 y estube buscando la solución hasta que llegue hasta aqui….
    ahora veo el monitor como corresponde…
    gracias

  19. andOs said

    Hola ayer me baje el iso d ubuntu 9.04 y no pude instalarlo pq se me plantaba el disco en pantalla negra, lo que hice fue instalarlo con wubi, lo pudde instalar, pero al momento de cargarlo no pude igual que la instalacion del iso quedaba en pantalla negra y nada mas, entonces hoy justo doy con tu blog y felizmente veo que las caracteristicas de la la pc coninciden con las mias osea tengo
    # Placa base: PCCHIPS P25G, con chipset P4M800.
    # Tarjeta Grafica Integrada: Via S3G UniChrome Pro IGP
    # Memoria compartida (VGA share memory size): 64MB
    lo unico que cambia es mi monitor Samsung SyncMaster 550v
    hice todos los pasos como indicas y parece que si funciona, pero luego me sale el mensaje de “Ubuntu, graphics low display”, y ahi quedo, desearia que me pudieras ayudar creo que ya casi estoy por dar con la solucion gracias a tu ayuda, me preguntaba si esta configuracion para Ubuntu Intrepid Ibex, es la misma para Ubuntu 9.04.
    Graxias

    • cmop17 said

      Hola, para tu monitor te propongo que sigas los pasos que menciono, pero que hagas la siguiente modificacion:

      Section "Monitor"
      Identifier "monitor01"
      VendorName "Samsung"
      EndSection

      Solo deja eso y elimina lo demas.

      Otra ayuda, que puedo darte es que no intentes correr el CD en modo Live sino que directamente en el menu que te sale para instalar selecciones la opcion de “Instalar Ubuntu”, muchas veces este modo carga mucho mas rapido.

      cualquier duda estoy para ayudarte, saludos.

  20. Felix said

    Hola, gracias amigo con lo que pones solucione mi problema de resolución

  21. Mateo said

    Gracias valor!!
    Anduvo todo!! te sarpastes! sos arto bicho!!

    un abrazo~!

  22. Jonnii said

    hola
    yo tengo una placa via s3g unichrome pro igp de 64 mb v 6.14.10.407
    se puede aumentar??
    o actualizar x lo menos
    gracias

    • Cmop said

      Hola, de manera general cuando la Tarjeta de Video utiliza memoria Compartida, debes entrar al Bios y ubicar una parte que diga “VGA Share Mermory Size”, tamaño de memoria compartida para VGA, alli estan los valores que puedes modificar, dependiendo de la placa con las teclas AvPag y RePag. Como dato adicional, nunca dejes su valor en “disable” o “none”.
      Saludos

      • Jonnii said

        sisi el problema es ke no tengo los drivers y hace dias ke me pide ke la actualize alguien ke me los pueda pasar si gracias🙂
        jony_89_32@hotmail.com

        Saludos😀

        • Cmop said

          Hola,

          Si estas en windows, entra alli, http://www.touslesdrivers.com/index.php?v_page=29
          Presiona LANCER LA DETECTION, descargaras el plugin y lo instalaras, y despues de eso reabriras esa pagina en tu navegador y automaticamente buscara todos los drivers de tu PC, entre ellos el de Video.

          Si estas en Ubuntu mayor a 8.10 este ya trae los drivers, ahora si necesitas reinstalarlos pues usa apt-get install xserver-xorg-video-unichrome, esa seria una posible solucion,
          saludos.

  23. pabloncho said

    Gracias amigo, me ha servido de maravilla

  24. titufo said

    Genial Cmop.
    Meses buscando cómo hacer que mi placa Via Nano con tarjeta Chrome 9 HC (CN896) pudiese reproducir los 1440×900 del monitor y por fin resuelto.
    A ver si consigo ahora activar los efectos de escritorio y activar el sonido.
    Muchas gracias colega😉

  25. jalfup said

    Gracias hermano, me cambie a linuxmint isadora y con la informacion, que proporcionaste, pude solucionar el problema de mi resolucion, gracias nuevamente

  26. Roberto said

    Gran aporte bro busque una solución por días hasta que di con esta y por fin pude cambiar la resolución gracias

  27. sergio said

    tanto tiempo buscando una solución para cambiar la resolución, se agradece el aporte.

    Para el que le interese, lo probé con el lubuntu 10.04.

  28. ciloide2 said

    Hola te puedo molestar con un problema que tengo. Tengo exactamente esa misma placa integrada en motherboard, el punto es que descargue Kali Linux 2.0 y nunca inicia el entorno gráfico, (consulté por varios lados, y todas me apuntan a que mi problema radica en las “X”, ( y como buen principianta ésta respuesta solo hace que google sin saber lo que estoy buscando y o como aplicar lo que encuentro). Con la versión anterior de Kali Linux, funcionaba pero con esta nueva ver. no se carga todo el proceso, intenta cargar el entorno gráfico (medio borroso) pero se corta y pantalla negra. Y hasta ahí llego alguna sugerencia? como puedo saber si el problema es que no reconoce mi placa o su resolución es no apta para que despliegue el entorno? por donde empezarías y como ?. En fin si quieres respondes si no gracias igual por leer, )te dejo una casilla por si quieres responder por ahí) cicloide2@yahoo.com.ar Gracias..

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s

 
A %d blogueros les gusta esto: